Thursday, October 16, 2014

AX2012 R3 Demo data: Failed to create a session; confirm that the user has the proper privileges to log on to Microsoft Dynamics.

Same error, same cause, slightly different solution.
When setting up a machine with the demo data given by Microsoft, you may encounter this error when synchronizing database.
The cause of this issue is that in the demo data there are three partitions, and there is no "admin" USERINFO records for "ps" and "ext" partitions. Since there is no existing USERINFO records for "ps" and "ext" partitions, I created two dummy user (just give them a userId and save. Don't enable them). Then go to SSMS and run:

UPDATE USERINFO
SET ID = 'Admin', Name = '[name]', Enable = 1, SID = '[sid]',NETWORKDOMAIN = '[domain]', NETWORKALIAS = '[alias]',PARTITION = [recid for 'ps' partition record]
WHERE ID = 'temp1'  

Repeat the above for 'ext' partition. Then the problem is solved.

EDIT: If you plan to use the 'ps' and 'ext' partitions, you'll also want to take care of security role assignments in SECURITYUSERROLE table. 

This posting is provided "AS IS" with no warranties, and confers no rights.

3 comments:

  1. Hello Folks,

    I getting following error while updating CU9 from RTM while running Launch Upgrade Database from software upgrade checklist.
    Failed to create a session; confirm that the user has the proper privileges to log on to Microsoft Dynamics.(C
    \Classes\Info\add,13,(S
    \Classes\ReleaseUpdateDB\getDataAreaIdsForPartition,22,(S
    \Classes\ReleaseUpdateCockpit\scheduleCommonScript,100,(S
    \Classes\ReleaseUpdateCockpit\scheduleScripts,116,(S
    \Classes\ReleaseUpdateCockpit\scheduleModule,36,(S
    \Classes\ReleaseUpdateCockpit\scheduleType,40,(S
    \Classes\ReleaseUpdateCockpit\scheduleScriptTypes,26,(S
    \Classes\ReleaseUpdateCockpit\scheduleUpgrade,49,(C
    \Forms\ReleaseUpdateCockpit\Methods\ScheduleScripts,23,(C
    \Forms\ReleaseUpdateCockpit\Designs\DesignList\RunButton\Methods\Clicked,10

    your quick response is appreciable.
    you send me mail on msnazia2012@gmail.com
    thanks

    ReplyDelete
    Replies
    1. First of all the post about does not specifically target your situation.
      Having said that, I assume you are upgrading to R2 or R3 CU9. Do check whether the account being used for upgrading have the proper rights in AX (and in each partition)
      Finally, I recommend you post your question to AX forum (https://community.dynamics.com/ax/f/33) to get more community experts opinion.

      Delete
    2. Ah hah, and I saw you did that already and also solved the issue. Glad it worked out for you.

      Delete